VLANs

Type of switch ports:
Access ports - port belongs to and carries the traffic of only one VLAN.
Traffic is both received and sent with no VLAN tagging. Anything arriving on the port is assumed to belong to the VLAN assigned to the port. Tagged packet would be dropped. Also, switches remove any VLAN information from the frame before it’s forwarded out to an access-link device.
Voice access ports - most switches will allow to add a second VLAN to an access port on a switch port for voice traffic. It’s still just an access port that can be configured for both data and voice VLANs.
Trunk port - 100 or 1000Mbps point-to-point link, carries the traffic of multiple VLANs—from 1 to 4,094 at a time (though it’s really only up to 1,005 unless it is extended VLANs). All vlans are allowed by default in a trunk port


static vlan - to assign switch ports to each VLAN.
dynamic vlan - to assign vlan on MAC, addresses, protocols, or application basis.
VLAN Management Policy Server (VMPS) - automatically maps MAC addresses to VLANs.


Vlan ranges:
      2-1000 - can create delete change
1002-1005 - reserved for Cisco defaults for FDDI and Token Ring
1025-4094 - extended range


Native VLAN definition:
The VLAN tag information is referred to as VLAN ID (VID).
The default VID for a port is referred to as the Port VID (PVID).
Each physical port has a parameter called PVID.
Every 802.1Q port is assigned a PVID value that is of its native VLAN ID (default is VLAN 1).
All untagged frames are assigned to the LAN specified in the PVID parameter. When a tagged frame is received by a port, the tag is respected. If the frame is untagged, the value contained in the PVID (port value) is considered as a tag.
Every trunk port has native vlan - vlan 1 usually, where all untagged frames travel.

GVRP stands for GARP (Generic Attribute Registration Protocol) VLAN Registration Protocol. It's a Layer 2 network protocol, for automatic configuration of switches in a VLAN network. Each VLAN switch is configured with the VLANs it is part of. GVRP will spread this information and configure the needed VLANs.




show interface trunk - to see what vlans are allowed in different ports



trunk ports, native vlan and encapsulation
Enter into vlan configuration mode:
vlan 2 :


vlan 2 name Sales - to assign a name to Vlan


sh vlan - to view configured vlans EtherCannel bundle wont show up in vlan database


switchport access vlan 3 - to assign a vlan
interface range - to chose several interfaces simultaneusly
switchport mode access - to to set an access port

Trunk

A trunk port can be configured as one of the following 5 different modes: on, off, desirable, auto, or nonegotiate.
switchport mode trunk - to set an trunk port
switchport mode dynamic auto - makes the interface able to convert to trunk
switchport mode dynamic desirable - makes the interface actively able to convert to trunk
switchport nonegotiate - prevents from generating DTP frames


DTP Dynamic Trunking Protocol - to configure a port as an access or trunk port, negotiates with the port on the other end of the link.


switchport trunk allowed vlan ?
switchport trunk allowed vlan remove 4 - to exclude vlan #4 from the trunk


switchport trunk allowed vlan all /no switchport trunk allowed vlan - to set to default


switchport trunk native vlan 40 - to make #40 vlan native (instead of 1)
in this case all switches should have their native vlan changed to 40


Pruning
Enabling pruning on server enables it in entire domain. Vlan 1 - never prune.
switchport trunk pruning vlan 3-4 - to enable pruning
Router configuratin for vlan:
int f 0/1.1 - to assign subinterface (locally significant, usually the same as vlan number)
encapsulation dot1q 1 - to specify encapsulation and vlan number
ip address 192.168.1.14 255.255.255.240 vlans should be configured according to their subnets
to set ip address on the switch:

int vlan 1 ip address 192.168.1.200 255.255.255.0 no shutdown



Configuring VTP
vtp mode server - to set server mode
vtp domain Madrid - to set domain name
vtp passwors 1234 - to set password
sh vtp status -
sh vlan brief -


Voice vlan Qos Class of sevice - set to 5 for voice traffic
QoS standard - 802.1p
switchport voice vlan - to enable voice vlan feature mls qos - Globally enables QoS