Routing Protocols
Interior Gateway Routing Protocols (IGRP)
Exterior Gateway Protocols (EGP) are used to communicate between ASes
AS - it is a collection of networks under a common administrative domain
Load-balance - when a router sends packets each link
Connected interface |
Static Route |
EIGRP |
IGRP |
OSPF |
RIP |
External EIGRP |
Unknown or 255 |
0 |
1 |
90 |
100 |
110 |
120 |
170 |
255 |
Static Routes
Router1(config)# ip route 10.5.6.0 255.255.255.0 fa0/0
Router1(config)# ip route 10.5.6.0 255.255.255.0 10.5.4.6
Default Routes
administrative distance (AD) - "stepen doveria"
By default administrative distance for static = 1 (or 0 if exit interface)
ip route 0.0.0.0 0.0.0.0 f 1/0
output of sh ip routes, static route is listed as directly connected :
permanent - keeps the entry in the routing table no matter what happens
ip route 0.0.0.0 0.0.0.0 10.0.0.1 permanent
RIP
- Split horizon -- Prevents loops between adjacent routers.
Rule: Never advertise a route out of the interface through which you
learned it!
- Poison reverse -- Prevents larger loops. Rule: Once you
learn of a route through an interface, advertise it as unreachable back
through that same interface!
- Holddown timer -- Prevents incorrect route information from
entering routing tables. Rule: After a route is advertised as down,
do not listen to routing updates on that route for a specific period of
time!
maximum hop count = 16
holdowns - defaualt are : update = 30 sec, invalid = 180 sec, holddown =
180, flush = 240
passive-interface f 2/0 - to specify the interface out of which rip shouldnot send updates,
but can still
receive RIP updates
RIPv2 :
- vlsm support,
- instead of broadcast updates it uses multicast 224.0.0.9
- allows MD5 authentication
- supports discontiguous networks
Eigrp
Support for VLSM/CIDR
Support for summaries and discontiguous networks
Communication via Reliable Transport Protocol (RTP) - to manage the communication of messages between EIGRP-speaking routers
uses 224.0.0.10
If EIGRP doesn’t get a reply from a neighbor, it will switch to using unicasts. After 16 failed unicast attempts, the neighbor is declared dead.
Diffusing Update Algorithm (DUAL):
- Backup route determination if one is available
- Support of VLSMs
- Dynamic route recoveries
- Queries for an alternate route if no route can be found
First, EIGRP routers maintain a copy of all of their neighbors’ routes, which they use to calculate their own cost to each
remote network. If the best path goes down, it may be as simple as examining the contents of the topology table to select the best replacement route.
Second, if there isn’t a good alternative in the local topology table, EIGRP routers very quickly ask their neighbors for help.
So, DUAL is responsible for selecting and maintaining information about the best paths.
Internal IEGRP route(from the same AS) AD = 90
External (from other AS or from OSPF) AD = 170
EIGRP supports different Network layer protocols through the use of protocol-dependent modules (PDMs).
Before EIGRP routers are willing to exchange routes with each other, they must become neighbors.
There are three conditions
- Hello or ACK received
- AS numbers match
- Identical metrics
successor route (successful!) is the best route.
feasible successor is a backup route.
by default auto-summary is on
after adding networks output of sh ip route
turning off auto-summary
after no auto-summary command output of sh ip route
3 Tables to store information:
Route table - current routes
Topology table - route advertisment about every route
Neighbor table - with whom neighborship relations has been established
EIGRP Metrics:
- Bandwidth (path bandwidth value )
- Delay (cumulative line delay)
- Load
- Reliability
- and also MTU
network adddresses are classful: B and A Classes
Router(config-router)#network 172.16.0.0
Router(config-router)#network 10.0.0.0
to stop interface from sending and receiving Hello packets, (in rip still
receives):
Router(config)#router eigrp 20
Router(config-router)#passive-interface serial 0/1
AS - doesnot matter which one
Corp(config)#router eigrp ?
<1-65535> Autonomous system number
Load-balance
to view -
Pod1R1(config)#router eigrp 10
Pod1R1(config-router)#maximum-paths ?
<1-6> Number of paths
to view maximum hop count -
Pod1R1(config)#router eigrp 10
Pod1R1(config-router)#metric maximum-hops ?
<1-255> Hop count
show ip EIGRP neighbors - to view only directly connected routers
The H field indicates the order in which the neighbor was discovered.
The hold time is how long this router will wait for a Hello packet to arrive from a specific neighbor
The uptime indicates how long the neighborship has been established.
The SRTT field is the smooth round-trip timer—an indication of the time it takes for a round-trip from this router to its neighbor and back.
This value is used to determine how long to wait after a multicast for a reply from this neighbor
The Retransmission Time Out (RTO) field, which is the amount of time EIGRP waits before retransmitting a packet from the retransmission queue to a neighbor.
The Q value indicates whether there are any outstanding messages in the queue—consistently large values would indicate a problem.
The Seq field indicates the sequence number of the last update from that neighbor— something that’s used to maintain synchronization and avoid duplicate or out-of- sequence processing of messages
show ip route eigrp
show ip EIGRP topology
Notice that every route is preceded by a P. This means that the route is in the passive state, which is a good thing because routes in the active state (A) indicate that the router has lost its path to this network and is searching for a replacement. Each entry also indicates the feasible distance, or FD, to each remote network plus the next-hop neighbor through which packets will travel to their destination. Plus, each entry also has two numbers in parentheses.
The first indicates the feasible distance, and the second the advertised distance to a remote network
debug EIGRP packet
debug EIGRP notification - to view changes and updates (like events in rip)
OSPF
2 steps to enable:
Router(config)#router ospf 1
Router(config-router)#network 10.1.0.0 0.0.15.255 area 0
router ospf 1 - this number is locally significant, the process ID number is not the same thing as the AS number used in IGRP/EIGRP routing. Process IDs do not need to match between routers.
commands to check ospf:
newtwork 10.0.0.19 255.255.255.255 area 0 - to specify the only interface of the router to participate in ospf
sh ip protocols, sh ip route
sh ip ospf interface -to view interfaces that are configured to advertise ospf networks, gives the following information:
- Area number
- Process ID
- Router ID
- Timer settings
- Adjacent routers
sh ip ospf
sh ip ospf neigh - Shows the neighbor router ID numbers
sh ip ospf database - to view topology table, to calculate shortest path
Area 0 = obligatory
ABR - area border router
ASBR - autonomos system border router
RID - router ID. (highest IP address loopback or interface).
hello packets are sent 224.0.0.5
Elections
ip ospf priority 0 - to exclude this router in DR Router election
No DR is assigned on any type of point-to-point link.
No DR/BDR is assigned on the NBMA point-to-multipoint due to the hub/spoke topology.
DR and BDR are elected on broad-cast and non-broadcast multi-access networks.
Frame Relay is a non-Broadcast Multi-Access (NBMA) network by default.
Routers broadcast LSPs to all routers (this process is known as flooding).
Routers send information about only their own links.
Link-state protocols send hello packets to discover new neighbors.
LSPs are sent at regular intervals and when any of the following conditions occur:
- There is a new neighbor
- A neighbor has gone down
- The cost to a neighbor has changed
Neighboring routers exchange LSAs (link-state advertisements) to construct a topological database.
Routing Protocol Comparison in .pdf format